Защита от эксплоита FragmBuf

Защита от эксплоита FragmBuf


Совсем недавно в сети появился эксплоит под названием FragmBuf, который кладет сервер, в большинстве случаев сервер падает и не перезагружается.

Автор: [WPMG]PRoSToTeM@

Признаки:
Сервер падает с ошибкой
SZ_GETSPACE: Overflow without FSB_ALLOWOVERFLOW set on net_message


Защита от эксплоита в виде metamod плагина.

Установка:

1) Залить папку FragBufFix с модулем в директорию /addons/ вашего игрового сервера.

2) Прописать в /addons/metamod/plugins.ini следующее:

Для linux:

linux addons/FragBufFix/FragBufFix.so


Для windows:

win32 addons\FragBufFix\FragBufFix.dll


Подгрузить модули можно не перезагружая сервер:

meta load addons\FragBufFix\FragBufFix.dll

Или

meta load addons/FragBufFix/FragBufFix.so


На nix* операционных системах можете воспользоваться вместо данного фикса правилом для iptables от Fire:

INPUT -p udp -m udp -d ИП_СЕРВЕРА --dport ПОРТ_СЕРВЕРА -m string --hex-string "|5c63 646b 6579 5c39 3837 6661|" --algo kmp -j DROP


Скачать защиту от эксплоита FragmBuf:
Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.

Комментариев 0